summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e797a494ccba..54a3d3d3d304 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bombono-dvd
pkgver=1.2.4
-pkgrel=2
+pkgrel=3
pkgdesc="DVD authoring program with nice and clean GUI"
arch=('i686' 'x86_64')
url="http://www.bombono.org"
@@ -19,6 +19,8 @@ source=("https://github.com/muravjov/${pkgname}/archive/${pkgver}.tar.gz"
"fix_c++11_literal_warnings.patch"
"autoptr2uniqueptr.patch"
"fix_deprecated_boost_api.patch"
+ "fix_throw_specifications.patch"
+ "fix_operator_ambiguity.patch"
"fix_ffmpeg30.patch")
install=bombono-dvd.install
sha256sums=('4f8c882a0c359ca8c182a627885c64aa271820eead2f9a64b34f1625c3b0a9d7'
@@ -27,6 +29,8 @@ sha256sums=('4f8c882a0c359ca8c182a627885c64aa271820eead2f9a64b34f1625c3b0a9d7'
'28be98eb36eb6422717df7048c8ee74927495e7d7829e17cb54d746befc238c4'
'4c29e9b19ba3bcf8c42c46aaea6c1411580629e581307a91f4d085fcdaa6eab6'
'a69f51f9d5bd6ebe26c13abeece9de012d110dcec944c76efbab59b6bc0ef915'
+ '72b3d6c76cbf98fb9287f7ee5b7a57b6febe2a635d50758c2451e376e3e6ca02'
+ '9d56f7d16c55a506b092dbec00789e4767963d6202d3d92b79ad389393d43c69'
'f6fd3a309987ac08b6f70132686c5a06bc7496fb6e1097539d6348f558d09502')
prepare() {
@@ -37,6 +41,8 @@ prepare() {
patch -Np1 -i "${srcdir}/autoptr2uniqueptr.patch"
patch -Np1 -i "${srcdir}/fix_deprecated_boost_api.patch"
patch -Np1 -i "${srcdir}/fix_ffmpeg30.patch"
+ patch -Np1 -i "${srcdir}/fix_throw_specifications.patch"
+ patch -Np1 -i "${srcdir}/fix_operator_ambiguity.patch"
# python2 fix
for file in $(find . -name '*.py' -print); do
sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file