summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a33516f2289b..fc1dadd3b516 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Guillaume Hayot <postblue@postblue.info>
# Author: Kjö Hansi Glaz <kjo@a4nancy.net.eu.org>
-# TODO: Fix broken help page
pkgname=bookletimposer
-pkgver=0.3.1
+pkgver=0.3
pkgrel=1
+epoch=1
pkgdesc="Achieve some basic imposition on PDF documents"
arch=('any')
url="http://kjo.herbesfolles.org/bookletimposer/"
license=('GPLv3+')
-depends=('python>=3.5' 'python-pypdf2>=1.26' 'python-gobject' 'desktop-file-utils')
-makedepends=('python-distutils-extra' 'pandoc')
+depends=('python>=3.5' 'python-pypdf2>=1.26' python-gobject desktop-file-utils)
+makedepends=(python-build python-installer python-wheel python-distutils-extra pandoc)
install=bookletimposer.install
-source=("https://git.codecoop.org/kjo/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-b2sums=('dbe93e90970c4862fa8b391ae62543463a902eba22e51784f7295daab02257cfc7a15d27d1fdad089637346ec2644c893d6d36c3920cb48e4a7ae381475ca1c1')
+source=("https://kjo.herbesfolles.org/$pkgname/archive/$pkgname-$pkgver.tar.gz")
+b2sums=('c78bf2e8c11e6003beba9e8565002037aec6089868b82aacf2f3a0b6184c96ce3cbb7cfa53b45f992f12f7496cca5c6ca177394cdca2c15a16682456775a721b')
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$pkgname-$pkgver"
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
ln -s /usr/share/pixmaps/bookletimposer.svg $pkgdir/usr/share/bookletimposer/bookletimposer.svg
}