summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b70e7d7923f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andrew Shark <ashark @ at @ linuxcomp.ru>
+pkgname=bookmarksync-git
+pkgver=0.1.1.r1.g936eec8
+pkgrel=1
+pkgdesc="sync file picker bookmarks for KDE and GTK"
+arch=(x86_64)
+url="https://github.com/jlu5/bookmarksync"
+license=('GPLv3')
+makedepends=(git)
+source=(git+https://github.com/jlu5/bookmarksync.git)
+sha256sums=("SKIP")
+
+build() {
+ cd ${pkgname%-git}/src
+ qmake
+ make -j$(nproc) # Read user's option from makepkg.conf? Example in notepadqq-git.
+}
+
+package() {
+ install -D ${pkgname%-git}/src/bookmarksync "${pkgdir}/usr/bin/bookmarksync"
+ install -D ${pkgname%-git}/bookmarksync.desktop "${pkgdir}/usr/share/applications/bookmarksync.desktop"
+}
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}