summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb81179fd670..5bae859ac9ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=boost-build
pkgver=1.60
-pkgrel=2
+pkgrel=3
pkgdesc="Boost.Build makes it easy to build C++ projects, everywhere."
arch=('any')
url="http://www.boost.org/build/"
license=('custom:boost')
-depends=('gcc' 'python')
-conflicts=('boost' 'boost-build-nightly')
+depends=('gcc' 'boost' 'python')
+conflicts=('boost-build-nightly')
source=("https://github.com/boostorg/build/archive/boost-${pkgver}.0.tar.gz"
"http://www.boost.org/LICENSE_1_0.txt")
md5sums=('987767d1e22e34e5b90e54ff6b526f40'
@@ -28,5 +28,9 @@ package() {
./b2 install --prefix=${pkgdir}/usr
+ # Removing b2 and bjam, already installed by boost
+ msg2 "Removing /usr/bin/b2 and /usr/bin/bjam files, already installed by boost"
+ rm -rf ${pkgdir}/usr/bin/
+
install -Dm644 ${srcdir}/LICENSE_1_0.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}