summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 708df2563e75..445788ba001c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=botsay
-pkgver=1.2.2
+pkgver=1.2.4
pkgrel=1
pkgdesc='Like cowsay, but with randomly generated ASCII robots and color support'
arch=(x86_64)
url='https://github.com/xyproto/botsay'
license=(MIT)
makedepends=(git go)
-source=("git+$url#tag=v$pkgver")
-md5sums=('SKIP')
+source=("git+$url#commit=3d80040f766ecab1a4e1cbf8b236b4171bd430bc") # tag: v1.2.4
+b2sums=(SKIP)
build() {
cd $pkgname
-
- go build \
- -asmflags "all=-trimpath=$PWD" \
- -buildmode=pie \
- -gcflags "all=-trimpath=$PWD" \
- -ldflags "-s -w -extldflags $LDFLAGS"
+ go build -v -mod=vendor -buildmode=pie -trimpath -ldflags="-s -w -extldflags \"${LDFLAGS}\""
}
package() {
cd "$pkgname"
-
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim: ts=2 sw=2 et: