summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 7 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1682c33cd4b..913b215ebaa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,25 @@
# Maintainer: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
-pkgname=boxtron-git
-_pkgname="${pkgname%-git}"
-pkgver=0.5.3.r6.8aa2e4e
-pkgrel=1
+pkgname=boxtron
+pkgver=0.5.2
+pkgrel=3
pkgdesc='Compatibility tool to run DOS games on Steam through native Linux DOSBox'
arch=('i686' 'x86_64')
-url="https://github.com/dreamer/$_pkgname"
+url="https://github.com/dreamer/$pkgname"
license=('GPL')
depends=('python' 'dosbox' 'inotify-tools' 'timidity++')
makedepends=('git')
optdepends=(
'steam: The Steam client'
'soundfont-fluid: required for MIDI support, but another soundfont can be used')
-source=("git+$url.git")
+source=("git+$url.git#tag=v$pkgver")
sha512sums=('SKIP')
-pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "$_pkgname"
- sed -i -E '/^tool_(name|dir) +=/s/$/-git/' Makefile
- sed -i -E '/^tool_name_display +=/s/$/ (git)/' Makefile
-}
-
check() {
- cd "$_pkgname"
+ cd "$pkgname"
make test
}
package() {
- cd "$_pkgname"
+ cd "$pkgname"
make DESTDIR="$pkgdir" prefix=/usr install
}