summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 125b157fd493..a0af17271090 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ license=('LGPL')
groups=('kf6')
makedepends=(
'extra-cmake-modules-git'
+ 'cmake'
'git'
'qt6-tools'
'python'
@@ -24,7 +25,7 @@ sha256sums=('SKIP')
pkgver(){
cd breeze-icons
- _ver="$(cat CMakeLists.txt | grep -m1 '(ECM' | grep -o "[[:digit:]]*" | paste -sd'.')"
+ _ver="$(cat CMakeLists.txt | grep -m1 'KF_VERSION' | grep -o "[[:digit:]]*" | paste -sd'.')"
echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
@@ -34,7 +35,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTING=ON \
-DBINARY_ICONS_RESOURCE=ON \
- -BUILD_WITH_QT6=ON # this is not ned at all
+ -DBUILD_WITH_QT6=ON # this is not ned at all
cmake --build build
}