summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a5e007fc692..b57d006cb76b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname="brig-git"
_pkgname="brig"
pkgver="develop"
-pkgrel="3"
+pkgrel="4"
pkgdesc="File synchronization on top of ipfs with git like interface and web based UI -- development branch"
arch=(x86_64 i686 armv7h aarch64)
license=("AGPLv3")
url="https://github.com/sahib/${_pkgname}"
depends=(go)
-makedepends=(git make)
+makedepends=(git)
provides=("brig")
source=("git+https://github.com/sahib/${_pkgname}")
@@ -18,12 +18,11 @@ sha256sums=("SKIP")
build() {
cd "${_pkgname}"
git checkout develop
- export GOBIN=bin/
- make
+ go run mage.go
}
package() {
cd "${_pkgname}"
- install -Dm755 "${srcdir}/${_pkgname}/bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 "${srcdir}/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
}