summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40ac65657058
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: ewolnux <thinux@gmx.fr>
+# Contributor: Libernux <dutchman55@gmx.com>
+pkgname="brother-dcp7055"
+pkgver="2.0.4"
+pkgrel=2
+pkgdesc="LPR and CUPS driver for the Brother DCP7055"
+arch=('i686' 'x86_64')
+url="http://solutions.brother.com/linux/en_us/"
+license=('custom:brother commercial license')
+depends=('cups')
+install='brother-dcp7055.install'
+source=(
+ "http://www.brother.com/pub/bsc/linux/dlf/dcp7055lpr-2.1.0-1.i386.rpm"
+ "http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7055-$pkgver-$pkgrel.i386.rpm"
+ 'cupswrapper-license.txt'
+ 'lpr-license.txt'
+)
+md5sums=(
+ '364b4c661fc8e5b4c623122df4fe1c5d'
+ '992ea8ef6100fc5df358d85db56d9437'
+ '97ad0cffd216059e9d1d3121899d8646'
+ '5e87a3dc0f3e3438c088eda0f3565f0d'
+)
+if test "$CARCH" == x86_64; then
+ depends+=('lib32-glibc')
+fi
+prepare() {
+# do not install in '/usr/local'
+ if [ -d $srcdir/usr/local/Brother ]; then
+ install -d $srcdir/usr/share
+ mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
+ rm -rf $srcdir/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
+ fi
+# setup cups-directories
+ install -d $srcdir/usr/share/cups/model
+ install -d $srcdir/usr/lib/cups/filter
+# go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
+ cd `find . -type d -name 'cupswrapper'`
+ if [ -f cupswrapper* ]; then
+ _wrapper_source=`ls cupswrapper*`
+ sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
+ sed -i '/^sleep/d' $_wrapper_source
+ sed -i '/^lpadmin/d' $_wrapper_source
+ sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
+ sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
+ sed -i 's|/model/Brother|/model|g' $_wrapper_source
+ sed -i 's|lpinfo|echo|g' $_wrapper_source
+ export srcdir=$srcdir
+ ./$_wrapper_source
+ sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ rm $_wrapper_source
+ fi
+# /etc/printcap is managed by cups
+ rm `find $srcdir -type f -name 'setupPrintcap*'`
+}
+package() {
+ cp -R $srcdir/usr $pkgdir
+ if [ -d $srcdir/opt ]; then cp -R $srcdir/opt $pkgdir; fi
+ install -m 644 -D cupswrapper-license.txt $pkgdir/usr/share/licenses/${pkgname}/cupswrapper-licence.txt
+ install -m 644 -D lpr-license.txt $pkgdir/usr/share/licenses/${pkgname}/lpr-licence.txt
+}