summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD99
1 files changed, 48 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abb3e818813e..bbbfac1bd9f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,65 @@
# Maintainer: Karol Babioch <karol@babioch.de>
-# Inspired by package brother-dcp130c
-pkgname='brother-ql710w'
-pkgver=1.1.4r0
+pkgname=brother-ql710w
+pkgver=3.1.5r0
pkgrel=1
pkgdesc='LPR and CUPS driver for Brother QL-710W label printer'
-url='http://solutions.brother.com/linux/en_us/'
+url='https://support.brother.com'
arch=('i686' 'x86_64')
license=('custom')
-depends='cups'
-if [ "$CARCH" = 'x86_64' ]; then
- depends+=('lib32-glibc')
-fi
-install="$pkgname.install"
-source=("http://download.brother.com/welcome/dlfp002197/ql710wlpr-${pkgver/r/-}.i386.rpm"
- "http://download.brother.com/welcome/dlfp002199/ql710wcupswrapper-${pkgver/r/-}.i386.rpm"
- 'LICENSE')
-sha256sums=('0aa58fcc86464977d5133fdb19af484dbf1beb2e12a6d5e22d98dc8da2bfede7'
- '0adf16a61ec94c62a001469ec70e23616ec49878ee0091b064a62022438ed30d'
- 'cdd1955a9996bc246ba54e84f0a5ccbfdf6623962b668188762389aa79ef9811')
+depends=('cups')
+install="${pkgname}.install"
+source=("https://download.brother.com/welcome/dlfp002197/ql710wpdrv-${pkgver/r/-}.i386.rpm")
+sha256sums=('00b881cea1668553fe40887375d72188f42e03893b73619e231893564b609721')
prepare()
{
- # do not install in '/usr/local'
- if [ -d $srcdir/usr/local/Brother ]; then
- install -d $srcdir/usr/share
- mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
- rm -rf $srcdir/usr/local
- sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
- fi
+ # Create CUPS directories
+ install -d "${srcdir}/usr/share/cups/model"
+ install -d "${srcdir}/usr/share/ppd"
+ install -d "${srcdir}/usr/lib/cups/filter"
- # setup cups directories
- install -d "$srcdir/usr/share/cups/model"
- install -d "$srcdir/usr/lib/cups/filter"
+ # Locate cupswrapper script
+ cd $(find -type d -name 'cupswrapper')
+ _cupswrapper=$(ls cupswrapper*)
- # go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
- cd `find . -type d -name 'cupswrapper'`
- if [ -f cupswrapper* ]; then
- _wrapper_source=`ls cupswrapper*`
- sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
- sed -i '/^sleep/d' $_wrapper_source
- sed -i '/^echo lpadmin/d' $_wrapper_source
- sed -i '/^lpadmin/d' $_wrapper_source
- sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
- sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
- sed -i 's|/model/Brother|/model|g' $_wrapper_source
- sed -i 's|lpinfo|echo|g' $_wrapper_source
- export srcdir=$srcdir
- ./$_wrapper_source
- sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
- sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
- rm $_wrapper_source
- fi
+ # Patch cupswrapper script
+ sed -i '/^sleep/d' ${_cupswrapper}
+ sed -i '/^echo lpadmin/d' ${_cupswrapper}
+ sed -i '/^lpadmin/d' ${_cupswrapper}
+ sed -i "s|/usr|${srcdir}/usr|g" ${_cupswrapper}
+ sed -i "s|/opt|${srcdir}/opt|g" ${_cupswrapper}
+ sed -i "s|/model/Brother|/model|g" ${_cupswrapper}
+ sed -i 's|lpinfo|echo|g' ${_cupswrapper}
- # /etc/printcap is managed by cups
- rm `find $srcdir -type f -name 'setupPrintcap*'`
-}
+ # Invoke cupswrapper script
+ export srcdir=${srcdir}
+ ./${_cupswrapper}
+
+ # Patch resulting filter
+ sed -i "s|${srcdir}||" ${srcdir}/usr/lib/cups/filter/*lpdwrapper*
-package() {
- cd "$srcdir"
+ # Remove cupswrapper script and templates
+ find "${srcdir}" -type d -name 'cupswrapper' -exec rm -rf {} +
- cp -R usr $pkgdir
- if [ -d opt ]; then cp -R opt $pkgdir; fi
+ # Remove unneeded script (i.e. /etc/printcap is managed by CUPS)
+ rm $(find "${srcdir}" -type f -name 'setupPrintcap*')
- install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Remove binaries for different architectures
+ if [ "${CARCH}" = 'x86_64' ]; then
+ find "${srcdir}" -type d -name 'i686' -exec rm -rf {} +
+ elif [ "${CARCH}" = 'i686' ]; then
+ find "${srcdir}" -type d -name 'x86_64' -exec rm -rf {} +
+ fi
}
+package()
+{
+ # Install actual content
+ cp -R "${srcdir}/usr" "${pkgdir}"
+ cp -R "${srcdir}/opt" "${pkgdir}"
+
+ # Handle license
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ find "${pkgdir}" -type f -name 'LICENSE*.txt' -exec mv -t "${pkgdir}/usr/share/licenses/${pkgname}" {} +
+}