summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34aa2bfe2ba7..b9515441f9e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
-# Maintainer: Tasos Latsas <tlatsas@gmx.com>
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contrinutor: Tasos Latsas <tlatsas@gmx.com>
# Contributor: Patrick Palka <patrick@parcs.ath.cx>
# Contributor: damir <damir@archlinux.org>
# Development: http://closure.ath.cx/aur-dev
pkgname=bs
pkgver=2.10
-pkgrel=2
+pkgrel=3
pkgdesc="The classic game of Battleships against the computer. Ncurses."
arch=('i686' 'x86_64')
url="https://www.catb.org/~esr/bs/"
license=('GPL2')
depends=('ncurses' 'hicolor-icon-theme')
-source=("http://www.catb.org/~esr/bs/bs-$pkgver.tar.gz")
-sha256sums=('1f8c1541fd13f481ff96df26d668658a7465da064801ae22ee584bd50f3a3107')
+source=("http://www.catb.org/~esr/bs/bs-$pkgver.tar.gz"
+ 'Makefile_fix.patch')
+sha256sums=('1f8c1541fd13f481ff96df26d668658a7465da064801ae22ee584bd50f3a3107'
+ 'a09e386c70ecedf421d38907fbe91364f880c894408ba82051f55104852551c5')
-build() {
- cd $pkgname-$pkgver
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -uNp2 -r- -i ../Makefile_fix.patch
+}
+build() {
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd $pkgname-$pkgver
-
+ cd "${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
}