summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5527c4f3d20..91546f63fcf5 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,20 @@
pkgname=bsnes
pkgver=107
-pkgrel=2
+pkgrel=3
pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use.'
arch=('x86_64')
url='https://byuu.org/emulation/bsnes/'
license=('GPL3')
depends=('libpulse' 'gtksourceview2' 'libxv' 'libao' 'openal' 'sdl2')
conflicts=('bsnes-classic' 'bsnes-plus')
-source=("https://download.byuu.org/""$pkgname""_v""$pkgver""-source.7z")
-sha256sums=('7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36')
+source=("https://download.byuu.org/""$pkgname""_v""$pkgver""-source.7z" 'package.patch')
+sha256sums=('7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36' '7fd8edb835667363a77cb9b2f58f5e5d2c87c32b249afe3edb26d5ae2eecbbd6')
prepare() {
cd "$pkgname""_v""$pkgver""-source"
- # Allow us to build as root
- sed -i '37 d; 38 d; 39 s/else //' higan/target-bsnes/GNUmakefile
+ patch --forward --strip=1 --input="${srcdir}/package.patch"
}
build() {