summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e49b03f64ae..aa3a246a351a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maarten de Boer <maarten@cloudstek.nl>
pkgname=bspwm-rounded-corners
pkgver=0.9.10
-pkgrel=1
+pkgrel=2
pkgdesc="Tiling window manager based on binary space partitioning"
arch=(x86_64)
url="https://github.com/phuhl/bspwm-rounded"
@@ -11,19 +11,23 @@ makedepends=(git)
optdepends=('sxhkd: to define keyboard and pointer bindings'
'xdo: for the example panel')
conflicts=(bspwm bspwm-git)
-source=("https://github.com/phuhl/bspwm-rounded/archive/refs/tags/$pkgver.tar.gz")
install=$pkgname.install
-sha256sums=('da72da3ab55af43f6cecef94d8545d9f6ded5c2840475971b0a2d968fa281c3a')
+
+_git_ref=98e96427aa4af1d7b0c2f0e45a5ef8bbd6407a0b
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phuhl/bspwm-rounded/archive/${_git_ref}.tar.gz")
+
+sha256sums=('76b8de33faf54633f315f246b48328cd9011ec449569e3e9ee7186b1b1834bb4')
build() {
- cd "$srcdir/bspwm-rounded-$pkgver"
+ cd "$srcdir/bspwm-rounded-${_git_ref}"
CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
make PREFIX=/usr
}
package() {
- cd "$srcdir/bspwm-rounded-$pkgver"
+ cd "$srcdir/bspwm-rounded-${_git_ref}"
make PREFIX=/usr DESTDIR="$pkgdir" install