summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac495d713f00..9e49b03f64ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,30 @@
-# Maintainer: xXR01I1Xx <xxr01i1xx@tuta.io>
+# Maintainer: Maarten de Boer <maarten@cloudstek.nl>
pkgname=bspwm-rounded-corners
-pkgver=0.9.9
+pkgver=0.9.10
pkgrel=1
pkgdesc="Tiling window manager based on binary space partitioning"
arch=(x86_64)
-url="https://github.com/dylanaraps/bspwm"
+url="https://github.com/phuhl/bspwm-rounded"
license=(BSD)
depends=(xcb-util xcb-util-wm xcb-util-keysyms)
makedepends=(git)
optdepends=('sxhkd: to define keyboard and pointer bindings'
'xdo: for the example panel')
conflicts=(bspwm bspwm-git)
-source=("git+https://github.com/baskerville/bspwm#tag=$pkgver"
- 'rounded-corners.patch')
+source=("https://github.com/phuhl/bspwm-rounded/archive/refs/tags/$pkgver.tar.gz")
install=$pkgname.install
-sha256sums=('SKIP'
- '7c5d39d8f0fed0045e87cee3aaf3fcd4f1d87da08491a7f2e816b85976745ca0')
-
-prepare() {
- cd $srcdir/bspwm
- echo "Applying patch"
- git apply $srcdir/rounded-corners.patch
-}
+sha256sums=('da72da3ab55af43f6cecef94d8545d9f6ded5c2840475971b0a2d968fa281c3a')
build() {
- make -C "$srcdir/bspwm" PREFIX=/usr
+ cd "$srcdir/bspwm-rounded-$pkgver"
+
+ CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
+ make PREFIX=/usr
}
package() {
- cd $srcdir/bspwm
+ cd "$srcdir/bspwm-rounded-$pkgver"
+
make PREFIX=/usr DESTDIR="$pkgdir" install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"