summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f3b1c7bfad2..dbcd19de6936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=buho-git
-pkgver=v1.2.1.r10.g610d337
+pkgver=v1.2.2.r1.g4860995
pkgrel=1
pkgdesc="Task and Note Keeper"
-arch=('x86_64')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
groups=('maui-apps')
url="https://invent.kde.org/maui/buho"
license=('GPL3')
depends=('ki18n' 'qt5-webview' 'mauikit-git' 'kio' 'syntax-highlighting' 'attica' 'mauikit-filebrowsing-git')
-makedepends=('git' 'extra-cmake-modules')
+makedepends=('git' 'extra-cmake-modules' 'qt5-tools' 'qt5-svg')
provides=('buho')
conflicts=('buho')
source=("git+$url.git")
@@ -24,10 +24,10 @@ pkgver() {
}
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build -S "${pkgname%-git}"
- make -C build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- make -C build DESTDIR="${pkgdir}" PREFIX=/usr install
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
} \ No newline at end of file