summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 28 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41a76b4f8f93..39ec6b49ba86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,26 @@
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: William Rea <sillywilly@gmail.com>
-pkgbase=buildbot-git
-pkgname=('buildbot-git' 'buildbot-worker-git')
-pkgver=1.2.0.r40.g16dff07ce
-pkgrel=1
+pkgname=buildbot-git
+pkgdesc="The Continuous Integration Framework"
+pkgver=1.2.0.r43.g55fc75395
+pkgrel=3
arch=('any')
url="https://buildbot.net"
license=("GPL")
-makedepends=('git'
- 'python-twisted' 'python-jinja' 'python-zope-interface' 'python-future'
- 'python-sqlalchemy-migrate' 'python-dateutil' 'python-txaio'
- 'python-autobahn' 'python-pyjwt')
-source=(git+https://github.com/buildbot/buildbot.git)
-sha256sums=('SKIP')
+depends=('python-twisted' 'python-jinja' 'python-zope-interface' 'python-future'
+ 'python-sqlalchemy-migrate' 'python-dateutil' 'python-txaio'
+ 'python-autobahn' 'python-pyjwt')
+makedepends=('git')
+checkdepends=('python-treq' 'python-boto3' 'python-mock' 'python-moto'
+ 'python-lz4' 'python-isort' 'python-pylint' 'python-pyenchant' 'flake8'
+ "buildbot-pkg-git=$pkgver" "buildbot-worker-git=$pkgver")
+source=(git+https://github.com/buildbot/buildbot.git
+ ignore-invalid-escape-sequence.patch
+ skip-linux-distro-test.patch)
+sha256sums=('SKIP'
+ 'eb85942f5d9f43ed46c8832f318314084dcde2e53f698bf104af28c3a449ef1f'
+ '42fc2a771034c4134006ed18b52916e668aba3e2046b2fe188c7abcb3cffc0a5')
pkgver() {
cd buildbot
@@ -26,21 +33,21 @@ pkgver() {
)
}
+prepare() {
+ cd buildbot
-package_buildbot-git() {
- depends=('python-twisted' 'python-jinja' 'python-zope-interface' 'python-future'
- 'python-sqlalchemy-migrate' 'python-dateutil' 'python-txaio'
- 'python-autobahn' 'python-pyjwt')
- pkgdesc="The Continuous Integration Framework"
+ patch -Np1 -i ../ignore-invalid-escape-sequence.patch
+ # This test relies on VERSION_ID field in /etc/os-release. On Arch Linux this
+ # field is missing.
+ patch -Np1 -i ../skip-linux-distro-test.patch
+}
+check() {
cd buildbot/master
- python setup.py install --root="$pkgdir" --optimize=1
+ TZ=UTC python setup.py test
}
-package_buildbot-worker-git() {
- pkgdesc="Buildbot Worker Daemon"
- depends=('python-twisted' 'python-future')
-
- cd buildbot/worker
+package() {
+ cd buildbot/master
python setup.py install --root="$pkgdir" --optimize=1
}