summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ecad41cdfe1..07744ab30e8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Rafael Fontenelle <rafaelff@gnome.org>
# Maintainer: Marko Semet <marko10_000@mailbox.org>
pkgname=buildbox-common
-pkgver=1.0.0
+pkgver=1.0.2
pkgrel=1
pkgdesc="Shared protocol-buffer definitions and various helper functions"
arch=(x86_64)
@@ -9,13 +9,14 @@ url="https://buildgrid.build"
license=('Apache')
depends=('gflags' 'google-glog' 'grpc' 'gtest')
makedepends=('benchmark' 'c-ares' 'cmake' 'git' 'gmock' ninja)
-source=("git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=1.0.0&commit=1be05b3d6a089d4f367ebc56f914fc1a9fdd117d")
+source=("git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=1.0.2&commit=4729bf8e7d633f0402066415e121c96bc3ca9a1f")
sha256sums=('SKIP')
build() {
mkdir -p build
cd build
- cmake ../buildbox-common \
+ sed -i 's/STATIC/SHARED/' ../buildbox-common/CMakeLists.txt
+ CXXFLAGS="-flto=auto -O2 -ffunction-sections -Wl,--gc-sections" cmake ../buildbox-common \
-G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
@@ -24,8 +25,8 @@ build() {
check() {
cd build
- echo "Sometimes 'streamingstandardoutputinotifyfilemonitor' fails, just rerun it."
- ninja test
+ echo "Sometimes 'executionstatsutils_tests' and 'streamingstandardoutputinotifyfilemonitor' fails, just rerun it."
+ CTEST_OUTPUT_ON_FAILURE=True ninja test
}
package() {