summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34508091f868..ffc4d98021e1 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,10 @@
pkgname=buku
pkgver=4.2.2
-pkgrel=3
-pkgdesc="Powerful command-line bookmark manager."
+pkgrel=4
+pkgdesc="Powerful command-line bookmark manager. CLI only."
arch=('any')
-depends=('python' 'python-beautifulsoup4' 'python-cryptography' 'python-urllib3' 'python-certifi' 'python-html5lib' 'python-appdirs' 'python-arrow' 'python-cffi' 'python-click' 'python-flask-admin' 'python-flask-api' 'python-flask-bootstrap' 'python-flask-paginate' 'python-flask-wtf' 'python-idna' 'python-itsdangerous' 'python-jinja' 'python-markupsafe' 'python-packaging' 'python-pyasn1' 'python-pycparser' 'python-requests' 'python-six' 'python-werkzeug')
+depends=('python' 'python-beautifulsoup4' 'python-cryptography' 'python-urllib3' 'python-certifi' 'python-html5lib')
makedepends=('make')
url="https://github.com/jarun/Buku"
license=('GPL3')
@@ -17,8 +17,7 @@ sha256sums=('08866f284a03454d9ee5bbb332da62e6ae1dfbe83ada75092453a7fd04fe62b3')
package() {
cd "$srcdir/Buku-$pkgver"
- install -Dm 644 $pkgname.1 "${pkgdir}/usr/share/man/man1/$pkgname.1"
- python setup.py install --root="${pkgdir}" --prefix=/usr
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
install -Dm644 auto-completion/fish/buku.fish "${pkgdir}/usr/share/fish/vendor_completions.d/buku.fish"
install -Dm644 auto-completion/bash/buku-completion.bash "${pkgdir}/etc/bash_completion.d/buku"
install -Dm644 auto-completion/zsh/_buku "${pkgdir}/usr/share/zsh/site-functions/_buku"