summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d21b6b853f1d..dc897e36be7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Cody P Schafer <archlinux at codyps.com>
_bpn=bustle
pkgname=${_bpn}-git
-pkgver=0.5.4.r2.g0a426c3
-pkgrel=2
+pkgver=0.6.2.r7.g7f663b6
+pkgrel=1
pkgdesc="A dbus profiler"
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/Bustle/"
@@ -26,7 +26,10 @@ pkgver() {
build() {
cd "$pkgname"
- runhaskell Setup configure -O --prefix=/usr "--docdir=/usr/share/doc/${pkgname}" --datasubdir="$pkgname"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --datasubdir="$pkgname"
runhaskell Setup build
}