summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 29 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3db12dffeff5..3d3c2de16047 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Eloy Garcia Almaden <eloy.garcia.pca@gmail.com>
pkgname=buttermanager
-pkgver=1.6.1
+pkgver=1.7
pkgrel=6
epoch=
pkgdesc="Graphical tool to create BTRFS snapshots, balance filesystems and upgrade the system safetly"
@@ -8,8 +8,8 @@ arch=('x86_64')
url="https://github.com/egara/buttermanager"
license=('GPL')
groups=()
-depends=('btrfs-progs' 'python>=3' 'python-pyaml')
-makedepends=('git' 'python-setuptools')
+depends=('btrfs-progs' 'python>=3')
+makedepends=('python>=3' 'git')
checkdepends=()
optdepends=()
provides=()
@@ -24,21 +24,34 @@ noextract=()
md5sums=('SKIP')
validpgpkeys=()
-build() {
- cd "$pkgname"
- # Dependencies and package installation
- python setup.py install --user
-}
-
package() {
- cd "$pkgname"
+ cd "$pkgname"
# Creating destination directory
- install -dm755 "$pkgdir/opt/$pkgname"
+ install -dm755 "$pkgdir/opt/$pkgname"
+
+ # Copying all the structure to the destination directory
+ cp -ar "$srcdir/$pkgname/$pkgname/" "$pkgdir/opt/$pkgname/"
+
+ # Copying requirements
+ echo -e "\n Copying resources..."
+ cp -ar "requirements.txt" "$pkgdir/opt/$pkgname/"
+
+ # Creating virtual environment
+ echo -e "\n Creating virtual environment..."
+ cd "$pkgdir/opt/$pkgname/"
+ python -m venv env
+
+ # Enabling virtual environment
+ echo -e "\n Enabling virtual environment..."
+ source env/bin/activate
- # Copying all the structure to the destination directory
- cp -ar "$srcdir/$pkgname/$pkgname/" "$pkgdir/opt/$pkgname/"
+ # Installing requirements
+ echo -e "\n Installing all the required modules into the virtual environment. Please wait..."
+ pip install --upgrade pip
+ pip install -r requirements.txt
- # Copying .desktop file and icon
- install -Dm644 "$srcdir/$pkgname/aur/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "$srcdir/$pkgname/aur/$pkgname.svg" "$pkgdir/opt/$pkgname/gui/$pkgname.svg"
+ # Copying .desktop file and icon
+ echo -e \n "Creating desktop icon. Finishing the installation"
+ install -Dm644 "$srcdir/$pkgname/aur/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname/aur/$pkgname.svg" "$pkgdir/opt/$pkgname/gui/$pkgname.svg"
}