summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a445e4f5725
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Buck Yeh <buck.yeh at gmail dot com>
+pkgname=bux
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc='A supplemental C++ library with functionalities not directly supported from Modern C++ standard.'
+arch=('x86_64')
+url='https://github.com/buck-yeh/bux.git'
+license=('MIT')
+groups=()
+depends=('fmt')
+makedepends=('cmake' 'make' 'gcc' 'git' 'binutils' 'fakeroot' 'gawk')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=() #"$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+prepare() {
+ rm -Rf "$pkgname"
+ mkdir -p "$pkgname"
+ cd "$pkgname" || return 1
+ git clone -b main --single-branch $url .
+}
+
+build() {
+ cd "$pkgname" || return 1
+ cmake .
+ make -j
+}
+
+check() {
+ cd "$pkgname" || return 1
+ if [[ ! -f src/libbux.a ]]; then
+ return 1
+ fi
+ for i in include/*.h ; do
+ return 0
+ done
+ return 1
+}
+
+package() {
+ cd "$pkgname" || return 1
+ mkdir -p "$pkgdir/usr/lib"
+ mkdir -p "$pkgdir/usr/include/$pkgname"
+ cp src/libbux.a "$pkgdir/usr/lib/"
+ cp include/*.h "$pkgdir/usr/include/$pkgname/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}