summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb6fe872aad5..7994309196e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: Gianluca Montecchi <gian at grys dot it>
+# Contributor: Gianluca Montecchi <gian at grys dot it>
# Contributor: Erol Aktay <e.aktay at gmail dot com>
pkgname=buzhug
pkgver=1.8
-pkgrel=4
+pkgrel=5
pkgdesc="a fast pure-Python database engine, using a Pythonic, no-SQL syntax"
arch=('any')
url="http://buzhug.sourceforge.net/"
license=("BSD")
depends=('python2')
-makedepends=('unzip')
-source=("http://downloads.sourceforge.net/buzhug/$pkgname-$pkgver.zip"
+source=("https://downloads.sourceforge.net/buzhug/$pkgname-$pkgver.zip"
'LICENSE')
md5sums=('a5c15b484c91a55db35e71447d2e709c'
'0fbf9b394a8e03fa25f013410cd92225')
@@ -17,12 +16,12 @@ md5sums=('a5c15b484c91a55db35e71447d2e709c'
build()
{
cd $pkgname-$pkgver
- python2 setup.py build || return 1
+ python2 setup.py build
}
package()
{
cd $pkgname-$pkgver
- python2 setup.py install --root=$pkgdir || return 1
+ python2 setup.py install --root="$pkgdir" --optimize=1
install -D -m644 $srcdir/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}