summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c506da79c02c..081f5ab96751 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: wilga <wilga at cat3 dot de>
pkgname=bwsyncandshare
-pkgver=10.4.321
+pkgver=10.6.447
pkgrel=1
pkgdesc="file sync and share client"
arch=('any')
url="https://bwsyncandshare.kit.edu"
license=('custom')
-# the upstream package includes a bundled Oracle jre8 but we install it as a dependency instead
-depends=('jre' 'gtk2')
+# the upstream package includes a bundled Oracle jre8 but we remove it
+# and list java-runtime a dependency instead
+# NOTE: current version seems to require oracle jre and does NOT run with openjdk
+depends=('java-runtime' 'gtk2')
-# curl cannot use https since this server doesn't send intermediate CA certs so we must use http.
-# no security issue since the sha256sum we check against was computed from a https-downloaded copy
-_tarball="bwSyncAndShare_v${pkgver}_Linux.tar.gz"
-source=("http://download.bwsyncandshare.kit.edu/clients/$_tarball"
+# need to download "Latest" version since no version-numbered tarball exists
+# this will break when a new version is published
+_tarball="bwSyncAndShare_Latest_Linux.tar.gz"
+source=("https://download.bwsyncandshare.kit.edu/clients/$_tarball"
"$pkgname-$pkgver.patch")
noextract=("$_tarball")
-sha256sums=('1a36c94563110dcfc4dc76dc2c3702e2e62ac605b59e343e12aff4a76059d8af'
- '3e0817014cf6b34e63a7ea02186190efdd392be08e5e07510a90622822c893cf')
+
+sha256sums=('9b3c876f494ceffd4a33b877200ae5c884e8ba72d56fe6a21ffa8733537092d0'
+ '0d86a522fe6891f22ad07a2f470fed7b2a690d41dad62d085cb9f1b9135af98e')
prepare() {
tar xvzf $_tarball --exclude="bwSyncAndShare/jre" # remove bundled Oracle jre