summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f95c720b6db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Vojtech Horky <AUR / hotspur>
+pkgname=bzr-bisect-bzr
+pkgver=84
+pkgrel=1
+pkgdesc="Bazaar plugin to find a bug using binary search"
+arch=('any')
+url="https://launchpad.net/bzr-bisect/"
+license=('GPL')
+depends=("python2" "bzr")
+makedepends=("bzr" "python2")
+source=()
+md5sums=()
+_bzrbranch="lp:bzr-bisect"
+_bzrname="bzr-bisect"
+
+build() {
+ cd "${srcdir}"
+ msg "Connecting to BZR server..."
+
+ if [ -d "${srcdir}/${_bzrname}" ] ; then
+ cd "${_bzrname}" && bzr pull "${_bzrbranch}"
+ msg "Local repository updated."
+ else
+ bzr co "${_bzrbranch}"
+ msg "BZR checkout done or server timeout"
+ fi
+}
+
+package() {
+ cd "${srcdir}/${_bzrname}"
+ python2 ./setup.py install --prefix=/usr --root "${pkgdir}"
+}