summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 531d3c459547..f3e7be8baec3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,37 @@
pkgname=c-lolcat
pkgver=r34.8e95919
-pkgrel=4
+pkgrel=5
pkgdesc="High-performance implementation of lolcat"
arch=('i686' 'x86_64')
url="https://github.com/jaseg/lolcat"
license=('WTFPL')
-depends=()
+depends=('musl')
makedepends=()
conflicts=('lolcat' 'pyhton-lolcat')
-source=("$pkgname"::'git+https://github.com/jaseg/lolcat.git')
+source=("${pkgname}"::'git+https://github.com/jaseg/lolcat.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}"
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
}
-prepare() {
- cd "$srcdir/$pkgname"
- git submodule update --init musl
-}
+#prepare() {
+# cd "${srcdir}/${pkgname}"
+# #git submodule update --init musl
+# #git submodule update --init memorymapping
+# git submodule init
+# git submodule update
+#}
build() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}"
make
}
package() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}"
mkdir -p "${pkgdir}/usr/bin"
- make DESTDIR="$pkgdir/usr/bin" install
+ make DESTDIR="${pkgdir}/usr/bin" install
}