summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8a40faa4925
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+# custom variables
+_hkgname=cabal2arch
+_licensefile=LICENSE
+
+# PKGBUILD options/directives
+pkgname=cabal2arch
+pkgver=1.2
+pkgrel=2
+pkgdesc="Create Arch Linux packages from Cabal packages."
+url="http://github.com/archhaskell/"
+license=("BSD3")
+arch=('i686' 'x86_64')
+makedepends=("ghc" "haskell-archlinux" "haskell-cmdargs" "haskell-mtl")
+depends=()
+options=('strip' 'staticlibs' )
+source=("https://github.com/archhaskell/cabal2arch/archive/v1.2.tar.gz")
+
+sha1sums=('18936e2bafb6059f56b4814216ac5874ab54fe56')
+
+# PKGBUILD functions
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --prefix=/usr --docdir=/usr/share/doc/${pkgname}
+ runhaskell Setup build
+}
+
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup copy --destdir=${pkgdir}
+}