summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c36006d46b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: M3NIX
+# Contributor: M3NIX
+pkgname=cacher
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="Cacher is a code snippet library for professional developers. Use it to build a technical knowledge base for you and your team."
+arch=('x86_64')
+url="http://www.cacher.io"
+license=('Copyright © 2018 Penguin Labs')
+groups=('')
+depends=('alsa-lib' 'atk' 'cairo' 'dbus' 'desktop-file-utils' 'electron' 'expat' 'fontconfig' 'freetype2' 'gconf' 'gdk-pixbuf2' 'glib2' 'gtk2' 'hicolor-icon-theme' 'libappindicator-gtk2' 'libcups' 'libnotify' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nspr' 'nss' 'opera' 'pango')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://cacher-download.nyc3.digitaloceanspaces.com/cacher_1.4.3_amd64.deb")
+sha512sums_x86_64=('05f1f44487d48bdcf110bda2dc4fdb1d50a9680610e6e528b42deff81517f58eead8cb34201fb6394dc70e9a55e77882374978ea6f03710cc440307f02cd1d24')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+}