summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ac63c688a7b..9dda1e1ba2a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,24 @@
# Contributor: Tarn Burton <twburton at gmail dot com>
pkgname=cadabra2
-pkgver=2.4.0.2
+pkgver=2.4.2.1
pkgrel=1
pkgdesc="A field-theory motivated approach to computer algebra"
arch=('x86_64')
url="https://cadabra.science"
license=('GPL')
conflicts=('cadabra2-git')
-depends=(boost-libs glibmm gmp gtkmm3 jsoncpp mathjax python-ipykernel python-matplotlib
- python-sympy sqlite texlive-latexextra texlive-science)
+depends=(boost-libs glibmm gmp gtkmm3 jsoncpp python python-gmpy2 jupyterlab python-matplotlib
+ python-sympy sqlite texlive-bin texlive-latexextra texlive-science)
-makedepends=(boost cmake)
+optdepends=('mathjax: Doxygen documentation'
+ 'doxygen: Doxygen documentation'
+ )
+
+makedepends=(boost cmake pybind11)
source=($pkgname-$pkgver.tar.gz::"https://github.com/kpeeters/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('a24c8636264f2278c16d4f2010ab92b497b292a3a5bc495557c70e457516e7fe')
+sha256sums=('9cdee23f92e99813f76be6864aa3b0cf4711c4635ea5f90ec9dcbef5858f4045')
prepare() {
mkdir -p "$srcdir/build"