summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2287dbd63a49..d0d7a43174fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,25 @@
pkgname=caffe
pkgver=1.0
-pkgrel=14
+pkgrel=15
pkgdesc='A deep learning framework made with expression, speed, and modularity in mind (cpu only)'
arch=('i686' 'x86_64')
url='https://caffe.berkeleyvision.org/'
license=('BSD')
-depends=(
+depends=('openblas' 'lapack' 'boost-libs' 'protobuf' 'google-glog' 'gflags'
+ 'hdf5' 'opencv' 'leveldb' 'lmdb' 'python' 'python-numpy' 'python-pandas')
+optdepends=(
# official repositories:
- 'openblas' 'lapack' 'boost-libs' 'protobuf' 'google-glog' 'gflags'
- 'hdf5' 'opencv' 'leveldb' 'lmdb' 'python' 'cython'
- 'python-numpy' 'python-scipy' 'python-matplotlib' 'ipython'
- 'python-h5py' 'python-networkx' 'python-nose' 'python-pandas'
- 'python-dateutil' 'python-protobuf' 'python-gflags' 'python-yaml'
- 'python-pillow' 'python-six'
+ 'cython' 'python-scipy' 'python-matplotlib' 'ipython' 'python-h5py'
+ 'python-networkx' 'python-nose' 'python-dateutil' 'python-protobuf'
+ 'python-gflags' 'python-yaml' 'python-pillow' 'python-six'
# AUR:
'python-leveldb' 'python-scikit-image' 'python-pydotplus'
# NOTE:
# python-pydotplus (or python-pydot) is required by python executable 'draw_net.py'
# https://github.com/BVLC/caffe/blob/1.0/python/caffe/draw.py#L7-L22
)
-makedepends=('boost' 'doxygen' 'texlive-core')
+makedepends=('boost' 'doxygen' 'texlive-core' 'texlive-latexextra' 'ghostscript')
provides=('caffe-cpu')
conflicts=('caffe-cpu')
replaces=('caffe-cpu')
@@ -36,7 +35,7 @@ sha256sums=('71d3c9eb8a183150f965a465824d01fe82826c22505f7aa314f700ace03fa77f'
prepare() {
cp -af "${srcdir}/Makefile.config" "${srcdir}/${pkgname}-${pkgver}"
- # fix build with opencv 4.0
+ # fix build with opencv 4
cd "${pkgname}-${pkgver}"
patch -Np1 -i "${srcdir}/caffe-1.0-opencv4-fix.patch"
}
@@ -44,14 +43,14 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
- make all pycaffe
+ make all pycaffe test
rm -rf doxygen
make docs distribute
}
check() {
cd "${pkgname}-${pkgver}"
- make test runtest
+ make runtest
}
package() {