summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cafb93ecab59..f8afafe0ade5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
pkgname=caffe2-git
-pkgver=0.7.0.r434.g4c76b747
-pkgrel=3
+pkgver=0.7.0.r439.g8c9da8ef
+pkgrel=1
pkgdesc='A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -28,7 +28,12 @@ depends=(
# missing:
# 'python2-nvd3'
)
-makedepends=('git' 'cmake' 'gcc5')
+makedepends=(
+ # official repositories:
+ 'git' 'cmake' 'gcc5' 'ninja'
+ # AUR:
+ 'confu-git' 'python-peachpy-git'
+)
provides=('caffe2')
conflicts=('caffe' 'caffe-cpu' 'caffe-git' 'caffe-cpu-git'
'caffe2' 'caffe2-cpu' 'caffe2-cpu-git')
@@ -36,6 +41,7 @@ options=('!emptydirs')
source=(
# main source:
"$pkgname"::'git+https://github.com/caffe2/caffe2.git'
+ 'external-nnpack-fix.patch'
# git submodules:
'submodule-pybind11'::'git+https://github.com/pybind/pybind11.git'
'submodule-nccl'::'git+https://github.com/nvidia/nccl.git'
@@ -56,6 +62,7 @@ source=(
'submodule-NNPACK_deps-psimd'::'git+https://github.com/Maratyszcza/psimd.git'
)
sha256sums=('SKIP'
+ '1c94a1ecc0fe2a52c50c9d1a7bfca655d60c08d48995b27c73aa22b6c375da54'
'SKIP'
'SKIP'
'SKIP'
@@ -94,6 +101,11 @@ prepare() {
# https://github.com/facebookincubator/gloo/issues/43
cd third_party/gloo
git checkout 21a5c8ea5e02edca03068790df3d7f7ba4e2d75b
+
+ # avoid compile errors with nnpack if system library is found
+ # https://github.com/caffe2/caffe2/pull/808
+ cd "${srcdir}/${pkgname}"
+ patch -Np1 -i "${srcdir}/external-nnpack-fix.patch"
}
pkgver() {
@@ -168,7 +180,7 @@ build() {
-DUSE_MPI:BOOL=ON \
-DUSE_NCCL:BOOL=ON \
-DUSE_NERVANA_GPU:BOOL=ON \
- -DUSE_NNPACK:BOOL=OFF \
+ -DUSE_NNPACK:BOOL=ON \
-DUSE_OPENCV:BOOL=OFF \
-DUSE_FFMPEG:BOOL=OFF \
-DUSE_OPENMP:BOOL=ON \