summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e39cc2a739e..539187647317 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
pkgname=caffeine-ng
-pkgver=4.0.2
+pkgver=4.2.0
pkgrel=1
pkgdesc="Status bar application able to temporarily inhibit the screensaver and sleep mode."
arch=(any)
url="https://codeberg.org/WhyNotHugo/caffeine-ng"
-license=(GPL3)
+license=("GPL-3.0-or-later")
depends=(
python-gobject
python-xdg
@@ -19,33 +19,36 @@ depends=(
python-wheel
python-pulsectl
libindicator-gtk3
+ libayatana-appindicator
)
optdepends=(
- "libappindicator-gtk3: AppIndicator support (eg: Plasma, Unity)."
+ # "libappindicator-gtk3: AppIndicator support (eg: Plasma, Unity)."
"xfconf: Support for Xfce presentation mode."
)
makedepends=(
git
- python-setuptools-scm
- python-build
- python-installer
+ meson
+ scdoc
)
conflicts=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
provides=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
replaces=(caffeine-oneclick caffeine-systray)
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+source=("caffeine-ng-$pkgver.tar.gz::https://codeberg.org/attachments/6da08199-604f-4f0f-b9dd-c50efe587965")
-md5sums=('86295a0ddc165e84ab492cc247b6ea43')
+sha512sums=('ff732b56baa96f9f8eb0d05b502c56612cbd5a9c48c65820724c3abbb9ad4e2770997285cb0e4a1617cc5c70c8881a015451b4c00a6513daada97b93920a2cf8')
build() {
- cd "$srcdir"/caffeine-ng-${pkgver}
- python -m build --wheel --no-isolation
+ cd "$srcdir/caffeine-ng-v${pkgver}-0-g5027f55"
+ arch-meson . build
+ meson compile -C build
}
-package() {
- cd "$srcdir"/caffeine-ng-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+check() {
+ cd "$srcdir/caffeine-ng-v${pkgver}-0-g5027f55"
+ meson test --no-rebuild --print-errorlogs -C build
+}
- # XXX: Broken: installs shared files into python's site-packages
- #python -m installer --destdir="$pkgdir" dist/*.whl
+package() {
+ cd "$srcdir/caffeine-ng-v${pkgver}-0-g5027f55"
+ DESTDIR="$pkgdir" meson install --no-rebuild -C build
}