summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD142
1 files changed, 47 insertions, 95 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e608ea79fcb1..8d856e08176f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,9 @@ pkgname=('calligra-braindump-git'
'calligra-devtools-git'
'calligra-extras-git'
'calligra-filters-git'
- 'calligra-flow-git'
- 'calligra-handbook-git'
+# 'calligra-flow-git'
+# 'calligra-handbook-git'
'calligra-karbon-git'
- 'calligra-kexi-git'
- 'calligra-krita-git'
'calligra-libs-git'
'calligra-plan-git'
'calligra-plugins-git'
@@ -15,18 +13,16 @@ pkgname=('calligra-braindump-git'
'calligra-stage-git'
'calligra-words-git'
'calligra-gemini-git')
-pkgver=r95678.9bf0d3a
+pkgver=r99515.ae439d4
pkgrel=1
arch=('i686' 'x86_64')
license=('FDL1.2' 'GPL2' 'LGPL')
url='http://www.calligra-suite.org/'
-makedepends=('cmake' 'automoc4' 'boost' 'kdepimlibs' 'kdeedu-marble'
- 'lcms2' 'libmariadbclient' 'freetds' 'xbase' 'libwpg' 'opencolorio'
- 'libwps' 'gsl' 'glew' 'fftw' 'poppler-qt' 'libkdcraw' 'libodfgen'
- 'openjpeg' 'kdegraphics-okular' 'pstoedit' 'vc' 'libvisio'
- 'libetonyek' 'libpqxx' 'libspnav' 'eigen' 'postgresql')
+makedepends=('khtml' 'kross' 'kreport-git' 'kproperty-git' 'kdiagram-git' 'okular-frameworks-git' 'kxmlgui' 'qt5-webkit'
+ 'kdelibs4support' 'poppler' 'qca-qt5' 'libvisio' 'libetonyek' 'kactivities' 'kio' 'ilmbase' 'lcms2' 'kxmlgui'
+ 'marble' 'kcalcore' 'akonadi-contact' 'knotifyconfig' 'okular-frameworks-git' 'poppler-qt5' 'qt5-quick1' 'libodfgen' 'threadweaver')
groups=('calligra-git')
-source=('calligra::git+git://anongit.kde.org/calligra#branch=calligra/2.9')
+source=('calligra::git+git://anongit.kde.org/calligra')
md5sums=('SKIP')
pkgver() {
@@ -53,19 +49,18 @@ build() {
fi
cd ${srcdir}/build
- cmake ../calligra -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_active=OFF \
- -DWITH_Soprano=OFF -Wno-dev
+ cmake ../calligra -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF -Wno-dev
make
}
+
package_calligra-filters-git() {
pkgdesc="Filters for the Calligra office suite"
- depends=('libodfgen')
- optdepends=('libwpg: Corel WordPerfect Graphics image importer'
- 'libwps: Microsoft Works file word processor format import'
- 'libvisio: Microsoft Visio import filter'
+ depends=('kdelibs4support' 'poppler' 'qca-qt5' 'khtml' 'libodfgen')
+ optdepends=('libvisio: Microsoft Visio import filter'
'libetonyek: Apple Keynote import filter')
conflicts=('koffice-filters' 'calligra-filters')
replaces=('koffice-filters' 'calligra-filters')
@@ -77,7 +72,7 @@ package_calligra-filters-git() {
package_calligra-libs-git() {
pkgdesc="Libraries for the Calligra office suite"
- depends=('kdepimlibs' 'kactivities' 'libkactivities4')
+ depends=('kactivities' 'qca-qt5' 'ilmbase')
conflicts=('koffice-interfaces' 'koffice-libs' 'koffice-pics'
'koffice-servicetypes' 'calligra-interfaces'
'calligra-pics' 'calligra-servicetypes' 'calligra-libs')
@@ -93,22 +88,19 @@ package_calligra-libs-git() {
package_calligra-plugins-git() {
pkgdesc="Plugins for the Calligra office suite"
- depends=('calligra-libs-git' 'calligra-filters-git' 'libspnav')
- optdepends=('kdeedu-marble: map shape for Calligra')
+ depends=('calligra-libs-git' 'calligra-filters-git' 'kio' 'kdiagram-git' 'ilmbase' 'lcms2' 'libspnav')
+ optdepends=('marble: map shape for Calligra')
conflicts=('koffice-plugins' 'koffice-kchart' 'calligra-plugins')
replaces=('koffice-plugins' 'koffice-kchart' 'koffice-kformula' 'calligra-plugins')
install=calligra.install
cd build/plugins
make DESTDIR="${pkgdir}" install
-
- cd ../3rdparty/kdchart
- make DESTDIR="${pkgdir}" install
}
package_calligra-karbon-git() {
pkgdesc="Create scalable vector drawings"
- depends=('calligra-libs-git' 'kdebase-runtime' 'pstoedit')
+ depends=('calligra-libs-git' 'kxmlgui')
optdepends=('calligra-filters-git: import/export filters'
'calligra-extras: extra calligra tools')
conflicts=('koffice-karbon' 'koffice-karbon-doc' 'calligra-karbon-doc' 'calligra-karbon')
@@ -119,68 +111,31 @@ package_calligra-karbon-git() {
make DESTDIR="${pkgdir}" install
}
-package_calligra-kexi-git() {
- pkgdesc="Develop desktop database applications"
- depends=('calligra-libs-git' 'glew' 'fftw')
- optdepends=('libmariadbclient: MariaDB driver'
- 'libpqxx: PostgreSQL driver'
- 'freetds: Sybase & MS SQL driver'
- 'xbase: XBase driver'
- 'calligra-sheets: Spreadsheet-to-Kexi-table import plugin'
- 'kdeedu-marble: map form widget'
- 'calligra-plugins: extra calligra plugins')
- conflicts=('koffice-kexi' 'koffice-kexi-doc' 'calligra-kexi-doc' calligra-kexi'')
- replaces=('koffice-kexi' 'koffice-kexi-doc' 'calligra-kexi-doc' 'calligra-kex')
- install=calligra.install
-
- cd build/kexi
- make DESTDIR="${pkgdir}" install
- cd ../doc/kexi
- make DESTDIR="${pkgdir}" install
-}
-
package_calligra-plan-git() {
pkgdesc="Calligra Project Management Component"
- depends=('calligra-words-git')
+ depends=('calligra-words-git' 'kcalcore' 'kreport-git' 'akonadi-contact' 'khtml' 'kdiagram-git' 'kdelibs4support')
conflicts=('koffice-kplato' 'calligra-kplato' 'calligra-plan')
replaces=('koffice-kplato' 'calligra-kplato' 'calligra-plan')
install=calligra.install
cd build/plan
make DESTDIR="${pkgdir}" install
-
- cd ../3rdparty/kdgantt
- make DESTDIR="${pkgdir}" install
}
package_calligra-stage-git() {
pkgdesc="Write presentation documents"
- depends=('calligra-plugins-git' 'kdebase-runtime')
+ depends=('calligra-plugins-git' 'qt5-webkit' 'kio')
conflicts=('koffice-kpresenter' 'koffice-kpresenter-doc' 'calligra-stage-doc' 'calligra-stage')
replaces=('koffice-kpresenter' 'koffice-kpresenter-doc' 'calligra-stage-doc' 'calligra-stage')
install=calligra.install
cd build/stage
make DESTDIR="${pkgdir}" install
- cd ../doc/stage
- make DESTDIR="${pkgdir}" install
-}
-
-package_calligra-krita-git() {
- pkgdesc="Edit and paint images"
- depends=('calligra-plugins-git' 'kdebase-runtime' 'opencolorio' 'libkdcraw'
- 'fftw' 'glew')
- conflicts=('koffice-krita' 'calligra-krita-doc' )
- replaces=('koffice-krita' 'calligra-krita-doc' )
- install=calligra.install
-
- cd build/krita
- make DESTDIR="${pkgdir}" install
}
package_calligra-sheets-git() {
pkgdesc="Write spreadsheet documents"
- depends=('calligra-libs-git' 'gsl' 'kdebase-runtime')
+ depends=('calligra-libs-git' 'gsl' 'kdelibs4support' 'knotifyconfig')
optdepends=('calligra-filters-git: import/export filters'
'calligra-plugins: extra calligra plugins'
'calligra-extras: extra calligra tools')
@@ -190,13 +145,11 @@ package_calligra-sheets-git() {
cd build/sheets
make DESTDIR="${pkgdir}" install
- cd ../doc/sheets
- make DESTDIR="${pkgdir}" install
}
package_calligra-words-git() {
pkgdesc="Word Processor"
- depends=('calligra-plugins-git' 'kdegraphics-okular')
+ depends=('calligra-plugins-git' 'okular-frameworks-git' 'kxmlgui')
optdepends=('calligra-extras: extra calligra tools')
conflicts=('koffice-kword' 'calligra-words')
replaces=('koffice-kword' 'calligra-words')
@@ -206,19 +159,19 @@ package_calligra-words-git() {
make DESTDIR="${pkgdir}" install
}
-package_calligra-handbook-git() {
- pkgdesc="Documentation for Calligra"
- conflicts=('koffice-handbook' 'calligra-handbook')
- replaces=('koffice-handbook' 'calligra-handbook')
- options=('docs')
-
- cd build/doc/calligra
- make DESTDIR="${pkgdir}" install
-}
+# package_calligra-handbook-git() {
+# pkgdesc="Documentation for Calligra"
+# conflicts=('koffice-handbook' 'calligra-handbook')
+# replaces=('koffice-handbook' 'calligra-handbook')
+# options=('docs')
+#
+# cd build/doc/calligra
+# make DESTDIR="${pkgdir}" install
+# }
package_calligra-braindump-git() {
pkgdesc="Notes and idea gathering"
- depends=('calligra-libs-git' 'kdebase-runtime')
+ depends=('calligra-libs-git' 'kxmlgui' 'qt5-webkit')
conflicts=('calligra-braindump')
replaces=('calligra-braindump')
install=calligra.install
@@ -227,22 +180,21 @@ package_calligra-braindump-git() {
make DESTDIR="${pkgdir}" install
}
-package_calligra-flow-git() {
- pkgdesc="Flowchart & Diagram Editing"
- depends=('calligra-words-git')
- optdepends=('calligra-karbon: to export the charts in various formats')
- conflicts=('calligra-flow-doc' 'calligra-flow')
- replaces=('calligra-flow-doc' 'calligra-flow')
- install=calligra.install
-
- cd build/flow
- make DESTDIR="${pkgdir}" install
-}
+# package_calligra-flow-git() {
+# pkgdesc="Flowchart & Diagram Editing"
+# depends=('calligra-words-git')
+# optdepends=('calligra-karbon: to export the charts in various formats')
+# conflicts=('calligra-flow-doc' 'calligra-flow')
+# replaces=('calligra-flow-doc' 'calligra-flow')
+# install=calligra.install
+#
+# cd build/flow
+# make DESTDIR="${pkgdir}" install
+# }
package_calligra-extras-git() {
pkgdesc="Calligra suite extras"
- depends=('calligra-libs-git')
- optdepends=('kdegraphics-okular')
+ depends=('calligra-libs-git' 'calligra-words-git' 'okular-frameworks-git')
conflicts=('calligra-tools' 'koffice-templates' 'calligra-templats' 'calligra-extras')
replaces=('calligra-tools' 'koffice-templates' 'calligra-templats' 'calligra-extras')
install=calligra.install
@@ -256,7 +208,7 @@ package_calligra-extras-git() {
package_calligra-devtools-git() {
pkgdesc="Calligra developer tools"
- depends=('calligra-libs-git')
+ depends=('calligra-libs-git' 'calligra-words-git' 'calligra-sheets-git' 'poppler-qt5' 'kdelibs4support')
conflicts=('calligra-devtools')
replaces=('calligra-devtools')
cd build/devtools
@@ -265,7 +217,7 @@ package_calligra-devtools-git() {
package_calligra-gemini-git() {
pkgdesc="QML interface for Calligra Words and Stage"
- depends=('calligra-words-git' 'calligra-stage-git')
+ depends=('calligra-words-git' 'calligra-stage-git' 'kxmlgui' 'qt5-quick1')
install=calligra.install
conflicts=('calligra-gemini')
replaces=('calligra-gemini')