summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 22 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30a5d5a2486a..d62fbd4c5ca5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,41 @@
+# Maintainer: Christopher Price <pricechrispy at gmail dot com>
# Contributor: Simon Legner <Simon.Legner@gmail.com>
# Contributor: Jakob Nixdorf <flocke@shadowice.org>
# Contributor: Bertram Felgenhauer <int-e@gmx.de>
-# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
pkgname=camlidl
-pkgver=1.07
+pkgver=1.12
_pkgver=${pkgver/\./}
pkgrel=1
pkgdesc="A stub code generator and COM binding for Objective Caml (OCaml)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/xavierleroy/camlidl"
license=(LGPL2.1)
depends=('ocaml')
+makedepends=('git')
options=(staticlibs)
source=("https://github.com/xavierleroy/$pkgname/archive/$pkgname$_pkgver.tar.gz"
- META.camlidl)
+ META.camlidl
+ patch.diff)
+sha256sums=('d6ab22a363f22798d303df3b0e54ba274f2c3d7ab7a3023fee1c73d8a21970aa'
+ 'SKIP'
+ 'SKIP')
build() {
+ #ls -alh
+ cp patch.diff "$srcdir/$pkgname-$pkgname$_pkgver"
+
cd "$srcdir/$pkgname-$pkgname$_pkgver"
cp config/Makefile.unix config/Makefile
+
+ #ls -alh
+ git apply -v patch.diff
+
+ #ls -alh /usr/lib/ocaml/Makefile.config
+ #mkdir -p /build/camlidl/pkg/camlidl//usr/lib/ocaml/
+ #ln -s /usr/lib/ocaml/Makefile.config /build/camlidl/pkg/camlidl//usr/lib/ocaml/Makefile.config
+ #ls -alh /build/camlidl/pkg/camlidl//usr/lib/ocaml/Makefile.config
+
make all
}
@@ -32,6 +50,3 @@ package() {
install -Dm644 "$srcdir/META.camlidl" "$_ocamldir/$pkgname/META"
}
-
-sha256sums=('aa00c826017ba5d56f7bbed4a1c2e3ab98318e32dd6cdff849a3bffb85597961'
- 'ed7c8db53b950f62bfe3d1f99081a42787f7b17358dcdcc0e842daacdd5c70b2')