summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2b1d093788f..ee013d20206a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Contributor: Anton Kudelin <kudelin at protonmail dot com>
# Contributor: oliver < a t > first . in-berlin . de
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-_pkgname=camlpdf
-pkgname=$_pkgname-git
-pkgver=2.2.1.r47.g1e8e698
+pkgname=camlpdf-git
+pkgver=2.3.1.r21.g7557db5
pkgrel=1
pkgdesc="PDF-processing-library for OCaml"
arch=('x86_64')
@@ -16,20 +16,20 @@ options=(!makeflags staticlibs)
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -c 2-
+ cd ${pkgname%-git}
+ git describe --tags | sed 's/-/.r/' | tr - .| cut -c2-
}
build() {
- cd $srcdir/$_pkgname
- OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
+ cd ${pkgname%-git}
+ OCAMLFIND_DESTDIR="$pkgdir"/$(ocamlfind printconf destdir)
make OCAMLFIND_DESTDIR="$OCAMLFIND_DESTDIR"
}
package() {
- cd ${srcdir}/$_pkgname
- OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
- mkdir -p $OCAMLFIND_DESTDIR
- OCAMLFIND_LDCONF="$pkgdir/$(ocamlfind printconf ldconf)"
+ cd ${pkgname%-git}
+ OCAMLFIND_DESTDIR="$pkgdir"/$(ocamlfind printconf destdir)
+ install -d $OCAMLFIND_DESTDIR
+ OCAMLFIND_LDCONF="$pkgdir"/$(ocamlfind printconf ldconf)
make install -d OCAMLFIND_DESTDIR="$OCAMLFIND_DESTDIR" OCAMLFIND_LDCONF="$OCAMLFIND_LDCONF"
}