summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4230c4f72e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gonçalo Camelo Neves Pereira <goncalo_pereira@outlook.pt>
+
+pkgname=can-utils
+pkgver=2018.02.0
+_pkgname=can-utils-${pkgver}
+pkgrel=1
+pkgdesc="Linux-CAN / SocketCAN user space applications"
+arch=('any')
+url="https://github.com/linux-can/can-utils"
+license=('GPLv2')
+makedepends=("git" "autoconf" "libtool")
+provides=("can-utils")
+conflicts=("can-utils-git")
+source=("https://github.com/linux-can/can-utils/archive/v2018.02.0.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}"
+ tar -xzf v2018.02.0.tar.gz
+ pwd
+ cd "${_pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make install
+}