summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 055e7bb7fbb7..b4d96ca326d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Ruben Di Battista <rubendibattista at gmail dot com>
_pkgname=cantera
pkgname="${_pkgname}-git"
-pkgver='2.5.1.r0.gb0bace782'
+pkgver=2.5.1.r1074.g80e93621f
pkgrel=1
pkgdesc='suite of tools for kinetics, thermodynamics, and transport processes'
arch=('x86_64')
@@ -10,14 +10,14 @@ url='https://cantera.org/'
license=('custom:Cantera Developers'
'custom:Sandia Corporation Contract AC04-94AL85000'
'custom:California Institute of Technology')
-depends=('eigen' 'sundials' 'boost' 'tcsh' 'cython' 'python-numpy')
-makedepends=('scons' 'git' 'gcc' 'fmt' 'doxygen')
-checkdepends=('gtest' 'gmock' 'python-ruamel-yaml')
+depends=('sundials' 'python-numpy' 'openmp' 'yaml-cpp' 'fmt')
+makedepends=('scons' 'git' 'gcc' 'doxygen' 'cython')
+checkdepends=('gtest' 'gmock' 'python-ruamel-yaml' 'python-pytest')
provides=('libcantera_shared.so=2-64')
install="$pkgname.install"
source=(git+https://github.com/Cantera/cantera.git)
md5sums=('SKIP')
-_python_v=$(python -V | awk '{print $2}')
+_python_v=$(python -c 'import sys; print(str(sys.version_info[0])+"."+str(sys.version_info[1]))')
pkgver() {
cd "$_pkgname"
@@ -52,5 +52,5 @@ package() {
# install cantera
scons install
# correct namcap warning directory-not-world-executable
- chmod 755 "$pkgdir/usr/lib/python${_python_v:0:3}/site-packages"
+ chmod 755 "$pkgdir/usr/lib/python${_python_v}/site-packages"
}