summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86a65462cc0e..b4d96ca326d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Tobias M. Baust <tobias.baust at tutanota dot com>
+# Maintainer: Ruben Di Battista <rubendibattista at gmail dot com>
_pkgname=cantera
pkgname="${_pkgname}-git"
-pkgver='2.5.1.r0.gb0bace782'
+pkgver=2.5.1.r1074.g80e93621f
pkgrel=1
pkgdesc='suite of tools for kinetics, thermodynamics, and transport processes'
arch=('x86_64')
@@ -9,13 +10,14 @@ url='https://cantera.org/'
license=('custom:Cantera Developers'
'custom:Sandia Corporation Contract AC04-94AL85000'
'custom:California Institute of Technology')
-depends=('eigen' 'sundials' 'boost' 'tcsh' 'cython' 'python-numpy')
-makedepends=('scons' 'git' 'gcc' 'fmt' 'doxygen')
-checkdepends=('gtest' 'gmock' 'python-ruamel-yaml')
+depends=('sundials' 'python-numpy' 'openmp' 'yaml-cpp' 'fmt')
+makedepends=('scons' 'git' 'gcc' 'doxygen' 'cython')
+checkdepends=('gtest' 'gmock' 'python-ruamel-yaml' 'python-pytest')
provides=('libcantera_shared.so=2-64')
install="$pkgname.install"
source=(git+https://github.com/Cantera/cantera.git)
md5sums=('SKIP')
+_python_v=$(python -c 'import sys; print(str(sys.version_info[0])+"."+str(sys.version_info[1]))')
pkgver() {
cd "$_pkgname"
@@ -25,7 +27,7 @@ pkgver() {
build() {
cd "$_pkgname"
# build cantera
- scons build \
+ scons -j $(nproc) build \
prefix="$pkgdir/usr" \
system_eigen='y' \
system_sundials='y' \
@@ -40,7 +42,8 @@ build() {
check() {
cd "$_pkgname"
- scons test
+ scons -j $(nproc) test
+ scons test-clean
}
package() {
@@ -49,6 +52,5 @@ package() {
# install cantera
scons install
# correct namcap warning directory-not-world-executable
- _python_v=$(python -V | awk '{print $2}')
- chmod 755 "$pkgdir/usr/lib/python${_python_v:0:3}/site-packages"
+ chmod 755 "$pkgdir/usr/lib/python${_python_v}/site-packages"
}