summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 12c70eeb6160..97ad18b914e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: kpcyrd <git@rxv.cc>
pkgname=cargo-flamegraph
-pkgver=0.1.10
+pkgver=0.1.11
pkgrel=1
pkgdesc="Cargo plugin that generates a flamegraph for a given workload"
url="https://github.com/ferrous-systems/cargo-flamegraph"
@@ -9,27 +9,25 @@ depends=('gcc-libs')
makedepends=('cargo')
arch=('i686' 'x86_64')
license=('MIT' 'APACHE')
-source=("${pkgname}-${pkgver}.tar.gz::https://crates.io/api/v1/crates/flamegraph/${pkgver}/download")
-sha512sums=('9afdd7b5739f128fcfd9e3b5aa77d7694b1e2d6086444843a0da17a87da27dc0e7b57f4b41a2e021e59f5bcafc8298b540f78a26e45be41c4dfd27cc683969d0')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ferrous-systems/flamegraph/archive/${pkgver}.tar.gz")
+sha512sums=('115edb277babad162a8eb75e20c1472edde0f4d9ecf6b83f2f3fd59ecfe3bbffdd02fc7ad1a9688d3b5da8139c64bbcf4e449205a25a913bb58c7cfcfacd00f2')
build() {
cd "flamegraph-${pkgver}"
- # https://github.com/ferrous-systems/flamegraph/issues/25
- # --locked doesn't work
- #cargo build --release --locked
- cargo build --release
+ cargo build --release --locked
}
check() {
cd "flamegraph-${pkgver}"
- # --locked doesn't work
- #cargo test --release --locked
- cargo test --release
+ cargo test --release --locked
}
package() {
cd "flamegraph-${pkgver}"
- install -Dm755 "target/release/${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm755 \
+ "target/release/cargo-flamegraph" \
+ "target/release/flamegraph" \
+ -t "${pkgdir}/usr/bin"
install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm644 LICENSE-MIT -t "${pkgdir}/usr/share/licenses/${pkgname}"
}