summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e01fb219c396..e667af22c93a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Jonas Malaco <jonas@protocubo.io>
pkgname=cargo-llvm-lines
-pkgver=0.4.7
-pkgrel=2
+pkgver=0.4.8
+pkgrel=1
pkgdesc="Count the number of lines of LLVM IR across all instantiations of a generic function"
arch=('any')
url='https://github.com/dtolnay/cargo-llvm-lines'
license=('Apache' 'MIT')
depends=('cargo' 'rust-nightly' 'rustfmt')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('80b59e77dee53834dd2b0769f5719fc053c197c8d452a561de4998cc99f65b92')
+sha256sums=('9988e22deb9457e9aea82bc9b28fa7c73b0ea93dba361b5b4e8760e49cd9dcdd')
build() {
cd "$pkgname-$pkgver"
- # note: upstream does not provide Cargo.lock
- cargo build --release --all-features --target-dir=target
+ cargo build --release --locked --all-features --target-dir=target
}
check() {