summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b53a63689e37..ef2593cbf8aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=cargo-script
-pkgver=0.2.0
+pkgver=0.2.9
pkgrel=1
pkgdesc="Quickly and easily run Rust \"scripts\""
url="https://github.com/DanielKeep/cargo-script"
-depends=('cargo')
+depends=('cargo' 'rust')
arch=('i686' 'x86_64')
license=('MIT')
-source=("git+https://github.com/DanielKeep/cargo-script.git#commit=11ad368ff6dfa862629b2d0864dcaa958caba33f")
+source=("git+https://github.com/DanielKeep/cargo-script.git#commit=614e60e5932e218ebff1e471303eb0d59870d03b")
sha256sums=('SKIP')
build() {
@@ -16,6 +16,10 @@ build() {
package() {
cd "$pkgname"
+
install -Dm755 target/release/run-cargo-script "$pkgdir/usr/bin/run-cargo-script"
install -Dm755 target/release/cargo-script "$pkgdir/usr/bin/cargo-script"
+
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}