summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d001c72b9f3..5567dab2edf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=carp
-pkgver=0.7.2
-pkgrel=2
+pkgver=0.8.0
+pkgrel=1
pkgdesc="EncFS gui and cli front-end"
arch=("any")
url="https://projects.deparis.io/projects/carp"
@@ -9,17 +9,11 @@ license=("WTFPL")
depends=("encfs" "python-gobject" "python-inotify>=0.2.9" "python-xdg")
optdepends=("rsync: sync support")
makedepends=("python-setuptools" "emacs")
-source=("https://git.deparis.io/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('44ff2439460dcbd5cf7a51346818ad5f07124310cacac75f487133c13c391085')
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make
-}
+source=("https://fossil.deparis.io/${pkgname}/tarball/${pkgver}.tar.gz")
+sha256sums=('088f1d7b2d7a5fd747af5f03223992b69ffbd337a51b62afd5bd50533e6b58dd')
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgver"
- make DEST="$pkgdir/usr" PYDEST="$pkgdir/" install
+ make dist DESTDIR="$pkgdir"
}