summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e6a0897702f..9974d30e8c32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,20 +22,20 @@
# Contributor: gentoo (part of 4.3 kernel patches)
# Contributor: Philip Muller @ Manjaro (4.4 kernel patch)
# Contributor: aslmaswd (acpi main script)
-# Contributor: npfeiler (libcl/opencl-icd-loader cleaning and 4.11 kernel patch)
+# Contributor: npfeiler (libcl/opencl-icd-loader cleaning, 4.11 and 4.12 kernel patch)
# Contributor: sling00 (4.10 kernel patch)
pkgname=catalyst-total
pkgver=15.9
-pkgrel=19
+pkgrel=20
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('dkms' 'linux>=3.0' 'linux<4.12' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
+depends=('dkms' 'linux>=3.0' 'linux<4.13' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -99,7 +99,9 @@ source=(
4.7-arch-cpu_has_pge-v2.patch
4.9_over_4.6-arch-get_user_pages_remote.patch
4.10-arch-sling00-virtual_address-acpi_get_table_with_size.patch
- 4.11-npfeiler-signal_vmf.patch)
+ 4.11-npfeiler-signal_vmf.patch
+ 4.12-npfeiler-PUD_OFFSET.patch
+ 4.12-arch-remove_clts.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
@@ -130,7 +132,9 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'37eef5103a11d8136979463e7bc31091'
'194cb44e9e2ab0e65b6267aca66d0400'
'05f6364db877d9c4bdf1592deda905b7'
- '8e53ba65a0aad42eb2ff771c1ace6609')
+ '8e53ba65a0aad42eb2ff771c1ace6609'
+ 'f090e47160403e4ba65d1e0de69973c9'
+ '782769206ed12ded10c347be3e476729')
build() {
@@ -324,6 +328,8 @@ package() {
patch -Np1 -i ../4.9_over_4.6-arch-get_user_pages_remote.patch
patch -Np1 -i ../4.10-arch-sling00-virtual_address-acpi_get_table_with_size.patch
patch -Np1 -i ../4.11-npfeiler-signal_vmf.patch
+ patch -Np1 -i ../4.12-npfeiler-PUD_OFFSET.patch
+ patch -Np1 -i ../4.12-arch-remove_clts.patch
# Prepare modules source files
install -dm755 ${pkgdir}/usr/src/fglrx-${pkgver}/2.6.x