summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b41446f7fa71..0d8e10cb6225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=cauchy-hg
_hgrepo=cauchy
pkgver=446.814aa99d9341
-pkgrel=2
+pkgrel=3
pkgdesc='Matlab/Octave to C++ transformer'
arch=('i686' 'x86_64')
url='https://bitbucket.org/cyrille/cauchy'
@@ -16,18 +16,20 @@ source=('hg+https://bitbucket.org/cyrille/cauchy')
md5sums=('SKIP')
pkgver() {
- cd ${srcdir}/$_hgrepo
+ cd $_hgrepo
printf "%s.%s" $(hg identify -n) $(hg identify -i)
}
build() {
- cd ${srcdir}/$_hgrepo
- cmake $srcdir/$_hgrepo -DCMAKE_BUILD_TYPE=debugfull \
+ cd $_hgrepo
+ [[ -d build ]] || mkdir build
+ cd build
+ cmake ../$_hgrepo -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd ${srcdir}/$_hgrepo
- make DESTDIR=${pkgdir} install
+ cd $_hgrepo
+ make DESTDIR="$pkgdir" install
}