summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d5bbcb0e145..c2cc14b82f05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=cccc
pkgver=3.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="C and C++ Code Counter, code metrics also for Ada and Java files"
arch=('i686' 'x86_64')
url="http://cccc.sourceforge.net/"
+depends=('gcc-libs')
license=('GPL')
-source=(http://downloads.sourceforge.net/sourceforge/cccc/$pkgname-$pkgver.tar.gz)
-md5sums=('7bd3ad868913a0beab2fde931737f928')
+source=(http://downloads.sourceforge.net/sourceforge/cccc/$pkgname-$pkgver.tar.gz
+gcc47.patch)
+md5sums=('7bd3ad868913a0beab2fde931737f928'
+ 'e1d2cb39fcac3f3c14eaff4f1e8f2825')
build() {
cd "$srcdir/$pkgname-$pkgver"
+
sed -e 's/su root -c "make -f install.mak"/make -f install.mak/' \
-i makefile || return 1
sed -e 's:/usr/local/bin:'$pkgdir'/usr/bin:' \
-e 's/\$(MKDIR)/\$(MKDIR) -p/' -i install/install.mak || return 1
- make || return 1
+ patch -p1 < ../gcc47.patch
+
+ make -j 1 || return 1
make DESTDIR="$pkgdir/" install
}