summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..684b4c04d5dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: eolianoe <eolianoe [at] gmail [DoT] com>
+# Contributor: Aaron Lindsay <aaron@aclindsay.com>
+# Contributor: Edvinas Valatka <edacval@gmail.com>
+# Contributor: Adrian Hühn <adrian.huehn@web.de>
+
+pkgname=ccnet-server
+pkgver=6.0.7
+pkgrel=1
+pkgdesc="A framework for writing networked applications in C."
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+url="https://github.com/haiwen/${pkgname}"
+license=('GPL2')
+depends=('libevent' 'libzdb' 'libsearpc' 'libldap' 'python2')
+makedepends=('vala' 'libmariadbclient')
+options=('!makeflags')
+source=("${pkgname}-v${pkgver}-server.tar.gz::${url}/archive/v${pkgver}-server.tar.gz"
+ "libccnet.pc.patch")
+sha256sums=('8e8fc38f8f8b3fc7aac7133c835b80df11fb219cf9b60b830cef9025a5daad64'
+ '66c3b02c3981db6a80819e0ae103bedadf8dfdf81405a7f75a9cba714acf973f')
+
+prepare () {
+ cd "${srcdir}/${pkgname}-${pkgver}-server"
+ patch -p1 -i "${srcdir}"/libccnet.pc.patch
+}
+
+build () {
+ cd "${srcdir}/${pkgname}-${pkgver}-server"
+ ./autogen.sh
+ ./configure --enable-ldap --enable-python --enable-console --prefix=/usr PYTHON=/usr/bin/python2
+ make
+}
+
+package () {
+ cd "${srcdir}/${pkgname}-${pkgver}-server"
+ make DESTDIR="$pkgdir" install
+}