summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f7897a3d516..d7fb3661f39d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,7 @@
-# Maintainer: Pierre Neidhardt <ambrevar@gmail.com>
+# Maintainer: Rudy Matela <rudy@matela.com.br>
+# Contributor: Rudy Matela <rudy@matela.com.br>
+# Contributor: Max R. P. Grossmann <m@max.pm>
+# Contributor: Pierre Neidhardt <ambrevar@gmail.com>
# Contributor: Thorsten Töpper <atsutane-tu@freethoughts.de>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
@@ -6,23 +9,24 @@
pkgname=ccrypt
pkgver=1.11
-pkgrel=1
-pkgdesc='A command-line utility for encrypting and decrypting files and streams'
+pkgrel=2
+pkgdesc="A tool for encrypting and decrypting files and streams."
arch=('x86_64')
-url="http://ccrypt.sourceforge.net"
+url="https://ccrypt.sourceforge.net/"
license=('GPL2')
-depends=('glibc')
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
+depends=('libxcrypt')
+makedepends=()
+source=("https://ccrypt.sourceforge.net/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha1sums=('6d20a4db9ef7caeea6ce432f3cffadf10172e420')
+sha256sums=('b19c47500a96ee5fbd820f704c912f6efcc42b638c0a6aa7a4e3dc0a6b51a44f')
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --mandir=/usr/share/man
- make
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
}
package() {
- cd $pkgname-$pkgver
-
- make DESTDIR="$pkgdir" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
}