summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17d75d3a56e6..f8964d4abb39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,35 +3,38 @@
_pkgname=ccx2
pkgname=ccx2-git
-pkgver=0.2.0.18.g04e2f10
-pkgrel=3
-pkgdesc="Console client for xmms2"
+pkgver=v0.2.0.r19.g7564773
+pkgrel=1
+pkgdesc="Console client for xmms2 (git version)"
arch=('any')
-url="http://github.com/palbo/ccx2"
+url="https://pflouret.github.io/ccx2/"
license=('BSD')
depends=('ncurses' 'python2' 'xmms2')
-optdepends=('python2-imaging: display Cover Art'
- 'python2-lxml: display lyrics')
+optdepends=("pil: for cover art display"
+ "python2-lxml: for lyrics display"
+ "python2-simplejson: for lyrics display, if python < 2.6")
provides=('ccx2')
conflicts=('ccx2')
-source=('git://github.com/palbo/ccx2.git')
+source=('git+https://github.com/pflouret/ccx2')
md5sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --always | sed -e 's|-|.|g' -e 's|v||'
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $srcdir/$_pkgname
+ cd "$_pkgname"
python2 setup.py build
}
package() {
- cd $srcdir/$_pkgname
+ cd "$_pkgname"
python2 setup.py install --root=$pkgdir
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/ccx2/LICENSE"
+ install -D -m644 LICENSE.urwid "$pkgdir/usr/share/licenses/ccx2/LICENSE.urwid"
}
+