summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d780814707fd..b9ea83ef9258 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=cdhist
-pkgver=3.6
+pkgver=3.7
pkgrel=1
pkgdesc="Linux shell cd history"
url="https://github.com/bulletmark/$pkgname"
license=(GPL3)
arch=(any)
depends=("python>=3.7")
-makedepends=(python-setuptools python-build python-installer python-wheel)
-install=install.sh
+makedepends=(python-setuptools python-build python-installer
+ python-wheel python-setuptools-scm)
+install="install.sh"
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('386bee11faffabdcc49dfd27b49fc341d518612a')
+sha1sums=('d277f164495f260eca99e67fb61ea2c19bc05f43')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver" python -m build --wheel --no-isolation
}
package() {