summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dc49edb356b..8f5ede18e9b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkg=cdi
flavour=
pkgname=${pkg}${flavour}
-pkgver=1.7.2
-fileID=12690
+pkgver=1.8.0
+fileID=13770
pkgrel=0
pkgdesc="CDI is a general purpose C-library for file IO in the geoscience area. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. CDI is the IO part of CDO"
url="https://code.zmaw.de/projects/cdi"
@@ -17,11 +17,11 @@ arch=(i686 x86_64)
backup=()
install=
source=(https://code.zmaw.de/attachments/download/${fileID}/${pkg}-${pkgver}.tar.gz)
-md5sums=('33a293e089d7f4c0f19bda1d490a20b6')
+md5sums=('6655ba13cfc285b5aa260de2eac7fd5a')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --with-netcdf=/usr --with-grib_api=/usr --with-szlib CFLAGS=-fopenmp LIBS='-lpng -lopenjpeg'
+ ./configure --prefix=/usr --with-netcdf=/usr --with-grib_api=/usr --with-szlib CFLAGS='-O2 -fopenmp' LIBS='-lpng -lopenjpeg'
make -j12 || return 1
}
package() {