summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 44 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61bd72a91264..96a3ca56d31c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,64 @@
# Maintainer: Michael Schubert <mschu.dev at gmail>
+# Maintainer: Eugene Dvoretsky <radioxoma at gmail>
pkgname=cellprofiler-analyst-git
-pkgver=20121017
+pkgver=2.0.4.r459.g7a96978
pkgrel=1
pkgdesc="Analysis software for cellular images"
arch=('i686' 'x86_64')
url="http://www.cellprofiler.org/"
license=('GPLv2')
-depends=('cellprofiler-git')
-makedepends=('git' 'python2-distribute')
+depends=(
+ 'wxpython2.8'
+ 'python2-numpy'
+ 'python2-scipy'
+ 'python2-matplotlib'
+ 'python2-imaging'
+ 'python2-pytz'
+ 'python2-verlib'
+ 'python2-javabridge'
+ 'python2-bioformats')
+optdepends=('cellprofiler: prepare data for CPA')
provides=('cellprofiler-analyst')
-conflicts=('cellprofiler-analyst')
+source=("$pkgname::git+https://github.com/CellProfiler/CellProfiler-Analyst#commit=7a96978"
+ "cellprofiler-analyst.desktop")
+sha256sums=('SKIP'
+ 'SKIP')
-_gitroot="git://github.com/CellProfiler/CellProfiler-Analyst.git"
-_gitname="CellProfiler-Analyst"
-
-build() {
- cd "$srcdir"
-
- msg "Connecting to GIT server...."
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
+prepare() {
+ cd "$srcdir/$pkgname"
+ # Should be fixed in the source three
+ sed -i '1i#!/usr/bin/env python2' ./CellProfiler-Analyst.py
+ rm -rf `find "$pkgdir" -name "tests" -type d`
+}
- cd "$srcdir/$_gitname/cpa"
+build() {
+ cd "$srcdir/$pkgname"
+ # force selection of wxpython2.8 (xargs helps handle spaces)
+ find . -name '*.py' -print0 | xargs -0 sed -i -e "s/^\(.*\)import wx$/\1import wxversion\n\1wxversion.select(\"2.8\")\n\1import wx/g"
- CP_HOME=/usr/lib/python2.7/site-packages/cellprofiler python2 setup.py build
+ # python2 setup.py build # Unusable build system (only for Mac now)
+ python2 -m compileall cpa
}
+# check() {
+# cd "$srcdir/CellProfiler-Analyst"
+# python2 setup.py test # Only for Mac now
+# }
+
package() {
- cd "$srcdir/$_gitname"
+ # python2 setup.py install --root="$pkgdir"/ --optimize=1 # Only for Mac now
pydir=`python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib()"`
-
-mkdir -p "$pkgdir/usr/bin"
-cat > "$pkgdir/usr/bin/cpa" << EOF
-#!/bin/sh
-python2 "$pydir/cpa/cpa.py"
-EOF
-chmod 755 "$pkgdir/usr/bin/cpa"
-
mkdir -p "$pkgdir/$pydir"
- cp -r cpa "$pkgdir/$pydir"
- python2 -m compileall "$pkgdir/$pydir/cpa/" || return 0
+ cd "$srcdir/$pkgname"
+ cp -r cpa "$pkgdir/$pydir"
+ install -Dm755 CellProfiler-Analyst.py "$pkgdir/usr/bin/cellprofiler-analyst"
+ install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/cellprofiler-analyst.desktop" "$pkgdir/usr/share/applications/cellprofiler-analyst.desktop"
}
-